summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2018-01-04 18:55:45 +0100
committerMax Kellermann <max@musicpd.org>2018-01-04 18:55:45 +0100
commit85d0bbd9577f37c6d42be48ca2976439ef4fe920 (patch)
treef060613964d352e5b432a54d194f8b664470ec61 /Makefile.am
parent414f00d6ae446a2e6f0bb28d68f6762ed2931934 (diff)
Makefile.am: add variable ZIPALIGN
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 316df7db5..592e75a77 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -292,9 +292,14 @@ clean-local:
libmpd.so: $(filter %.a,$(src_mpd_LDADD)) libmain.a
$(AM_V_CXXLD)$(CXXLD) -shared -Wl,--no-undefined,-shared,-Bsymbolic -llog -lz -o $@ $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) src/libmain_a-Main.o $(src_mpd_LDADD) $(LIBS)
+ANDROID_SDK_BUILD_TOOLS_VERSION = 20.0.0
ANDROID_SDK_PLATFORM = android-17
+
+ANDROID_BUILD_TOOLS_DIR = $(ANDROID_SDK)/build-tools/$(ANDROID_SDK_BUILD_TOOLS_VERSION)
ANDROID_SDK_PLATFORM_DIR = $(ANDROID_SDK)/platforms/$(ANDROID_SDK_PLATFORM)
+ZIPALIGN = $(ANDROID_BUILD_TOOLS_DIR)/zipalign
+
android/build/build.xml: android/AndroidManifest.xml
rm -rf android/build
mkdir -p android/build/include android/build/res android/build/src/org
@@ -334,10 +339,8 @@ android/build/bin/$(APK_NAME)-release-unsigned.apk: $(APK_DEPS)
android/build/bin/$(APK_NAME)-release-unaligned.apk: android/build/bin/$(APK_NAME)-release-unsigned.apk
jarsigner -digestalg SHA1 -sigalg MD5withRSA -storepass:env ANDROID_KEYSTORE_PASS -keystore $(ANDROID_KEYSTORE) -signedjar $@ $< $(ANDROID_KEY_ALIAS)
-ANDROID_SDK_BUILD_TOOLS_VERSION = 20.0.0
-
android/build/bin/$(APK_NAME).apk: android/build/bin/$(APK_NAME)-release-unaligned.apk
- $(ANDROID_SDK)/build-tools/$(ANDROID_SDK_BUILD_TOOLS_VERSION)/zipalign -f 4 $< $@
+ $(ZIPALIGN) -f 4 $< $@
endif