summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2016-11-22 12:25:52 +0100
committerMax Kellermann <max@musicpd.org>2016-11-22 16:49:31 +0100
commit95e2bec215b17e11601edf5456eaf0e73ccc944d (patch)
tree7b1471f36e519ec9a0ff2970401b08ada677cf46 /Makefile.am
parent72c96052b4f4c18959fe0fb374bc8c17cb9c19fe (diff)
decoder/DecoderPlugin: container_scan() returns forward_list<DetachedSong>
Speed up container_scan() again, by eliminating the need to call scan_file() for each item.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b71cb0e41..b73efecb0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1894,6 +1894,7 @@ test_run_decoder_LDADD = \
test_run_decoder_SOURCES = test/run_decoder.cxx \
test/FakeDecoderAPI.cxx test/FakeDecoderAPI.hxx \
test/ScopeIOThread.hxx \
+ src/DetachedSong.cxx \
src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/ReplayGainInfo.cxx
@@ -1915,6 +1916,7 @@ test_read_tags_LDADD = \
test_read_tags_SOURCES = test/read_tags.cxx \
test/FakeDecoderAPI.cxx test/FakeDecoderAPI.hxx \
test/ScopeIOThread.hxx \
+ src/DetachedSong.cxx \
src/Log.cxx src/LogBackend.cxx \
src/IOThread.cxx \
src/ReplayGainInfo.cxx
@@ -1946,6 +1948,8 @@ test_ContainerScan_LDADD = \
libsystem.a \
libutil.a
test_ContainerScan_SOURCES = test/ContainerScan.cxx \
+ src/DetachedSong.cxx \
+ src/SongSave.cxx src/TagSave.cxx \
src/Log.cxx src/LogBackend.cxx \
src/ReplayGainInfo.cxx \
$(DECODER_SRC)