summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Guillem <thomas@gllm.fr>2014-10-19 15:46:50 +0200
committerMax Kellermann <max@musicpd.org>2018-08-20 00:07:35 +0200
commit14d3a7ae83cd8724308a82775ee8946befcfe435 (patch)
treeb4f6c5ac62401aade9575e8f65f3ba9f73ee43e5 /Makefile.am
parentf37ab5482b187d1f18427239ad055da4e751bcb4 (diff)
android: use a gray notification icon
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fc0670220..6e2d96cae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -328,7 +328,7 @@ $(ANDROID_XML_RES_COPIES): $(ANDROID_XML_RES)
@$(MKDIR_P) $(dir $@)
cp $(patsubst android/build/%,$(srcdir)/android/%,$@) $@
-android/build/resources.apk: $(ANDROID_XML_RES_COPIES) android/build/res/drawable/icon.png
+android/build/resources.apk: $(ANDROID_XML_RES_COPIES) android/build/res/drawable/icon.png android/build/res/drawable/notification_icon.png
@$(MKDIR_P) android/build/gen
$(AAPT) package -f -m --auto-add-overlay \
--custom-package org.musicpd \
@@ -362,6 +362,9 @@ android/build/res/drawable/icon.png: mpd.svg
mkdir -p $(@D)
rsvg-convert --width=48 --height=48 $< -o $@
+android/build/res/drawable/notification_icon.png: android/build/res/drawable/icon.png
+ convert $< -colorspace Gray -gamma 2.2 $@
+
.DELETE_ON_ERROR: android/build/unsigned.apk
android/build/unsigned.apk: android/build/classes.dex android/build/resources.apk android/build/lib/$(ANDROID_ABI)/libmpd.so
cp android/build/resources.apk $@