summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@musicpd.org>2017-01-03 07:25:14 +0100
committerMax Kellermann <max@musicpd.org>2017-01-08 14:40:20 +0100
commit58fb36bdb9efc058061fa5b35bb910a759be4381 (patch)
treece70e9104aa2550b325d9e7251fbdace6f3db69a /Makefile.am
parent4297a7b0a494c090b574fda13d3808c1ee30cefd (diff)
storage/http: new storage plugin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index de02ebaa2..cdc621d57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -699,6 +699,8 @@ libstorage_a_CPPFLAGS = $(AM_CPPFLAGS) \
STORAGE_LIBS = \
libstorage.a \
+ $(CURL_LIBS) \
+ $(EXPAT_LIBS) \
$(NFS_LIBS) \
$(SMBCLIENT_LIBS)
@@ -714,6 +716,12 @@ libstorage_a_SOURCES += \
src/storage/plugins/NfsStorage.cxx src/storage/plugins/NfsStorage.hxx
endif
+if ENABLE_WEBDAV
+libstorage_a_SOURCES += \
+ src/lib/expat/ExpatParser.cxx \
+ src/storage/plugins/CurlStorage.cxx src/storage/plugins/CurlStorage.hxx
+endif
+
endif
# neighbor plugins
@@ -1768,6 +1776,10 @@ test_run_storage_SOURCES = \
test/ScopeIOThread.hxx \
test/run_storage.cxx
+if ENABLE_WEBDAV
+test_run_storage_SOURCES += $(CURL_SOURCES)
+endif
+
endif
test_run_input_LDADD = \